Materiały, dyskusje dotyczące projektów AVT, których kuratorem jest ES2

***** Musisz się zalogowac aby oglądac całe forum *****

Nie jesteś zalogowany na forum.

#1 2017-09-30 23:42:21

r-mik
Administrator
Dołączył: 2017-09-23
Liczba postów: 34
Windows XPFirefox 52.0

Relacje z prac

Pierwsze kroki poczynione.
https://es2.000webhostapp.com/5571_2017-09-28-129.mp4
Idzie dobrze, mierzy napięcie, spaliłem zielony segment C w czterech wyświetlaczach :-) Elamax znów zrobił błąd na PCB (2 sa ok, jedna z błędem, oczywiście ta, którą zacząłem składać).


Zmiana koloru, widać uszkodzenia zielonych segmentów C.
https://es2.000webhostapp.com/Panelowy_ … ielone.mp4


Automatyczna zmiana zakresu:
https://es2.000webhostapp.com/Panelowy_ … zmiana.mp4
Pod koniec pomiar napięcia odniesienia. Widać są małe problemy. To, że wynik za niski to problem elementów RC ale to, ze wynik skacze to juz inna bajka. Czaka mnie więc trochę pracy.


Pomiar relatywny. Przy tym rodzaju pomiarów automatyczna zmiana zakresu jest wyłączona:
https://es2.000webhostapp.com/Panelowy_ … atywny.mp4


Juto (dziś) zabiorę się za pomiar prądu.
No i prąd mierzę. Na filmiku 0,53A na boczniku 0,1R.
https://es2.000webhostapp.com/Panelowy_ … _530mA.mp4
W takiej sytuacji, na boczniku,i odkład się 53mV. Przy pomiarach prądów do 2A używam wzmacniacza x10, Max prąd to 20A i wynika z mocy zastosowanego rezystora.
Przy pomiarze widać wpływ rezystancji wejściowej multimetru na wynik. Szkoda, ze przez Internet nie można przesłać zapachów, bo tylko ja czuje ten "elektroniczny" zapach grzejącego się rezystora obciążenia, bo obciążenie aktywne leży w piwnicy i czeka na zamontowanie w obudowie.

Widać niestabilny wynik.  Zabieram się za szukanie problemu.


Dzień później
Pół dnia straciłem na zamontowanie obciążenia aktywnego w obudowie i testy amperomierza.  Po południu zabrałem się za szukanie przyczyny niestabilnego wyniku. Problemem była napięcie -5V. Wytwarzałem je w ICL7660. Niezbyt dobrej jakości napięcie nie przeszkadza układowi ICL7135 czy wzmacniaczom operacyjnym natomiast kluczom 74HC4051 już tak.  No i podczas prób z zewnętrznym zasilaczem -5V ugotowałem ICL7660 i oba 4051. Na szczęście pozostałem układy sa ok.  Dziś juz nie chce mi sie robić. Jutro tez jest dzień. Wlutuję 4051, uruchomię zasilacz -5V, soft praktycznie skończony.


Drugi dzień
Po zrobieniu zasilacza napięcia ujemnego problem zakłóceń mniejszy ale jest:
Panelowy_Y-Wy4051_i_B-Udd4051.jpg
Przekłada to sie na ofset 23mV ale co gorsza "pływanie" wyniku pomiaru. Mała modyfikacja i:
Panelowy_Y-Wy4051.jpg
ofset 6mV a wynik mniej pływa.
Dziś trochę czasu poświęciłem na obciążenie aktywne. Teraz ma swój zasilacza, miernik osobne uzwojenia na transformatorze, dzięki czemu pomiar prądu nie jest fałszowany o 160mA.


Dzień trzeci
Złożę następna PCB wyświetlaczy, bo denerwuje mnie brak niektórych zielonych segmentów (teraz wyświetlam je jak pomarańcz). Mam kilka dylematów, które trzeba jakoś rozwiązać, np jak wybierać zakres pomiarowy prądu. Może użyje ADC AVR-ka. Szybko zmierzy wszystkie wejścia pomiaru prądu i dla ICL7135 wybierze te, na którym ma jakieś odczyty. A co jeśli ma na kilku? Moża pomysleć o wyborze wejścia przy pomocy USB i zapamiętać w eeprom. Może jakiś inny sposób (np opcja konfiguracji przy starcie urządzenia)?


Dzień czwarty
Na tą chwile prace zakończone. Uruchomiłem komunikację po USB.  Zrobiłem projekt PCB HUB-a. Jak dostane gotowe PCB to podłączę trzy mierniki, dopisze wykrywanie kolizji transmisji i przetestuję jego działanie.


Trochę o USART. W podstawowej wersji komunikacja przebiega po USB (konwerter na FT230). Docelowo jednak kilka mierników ma być połączonych do HUB-a. Ten będzie zbierał wyniki z mierników i wysyłał po USB. W takiej sytuacji, w HUB-ie, każdy kanał miernika (izolacja optyczna) będzie "zapętlony" (miernik będzie miał echo tego co wysyła), a wszystkie kanały będą tworzyć sumę WireAnd. Dzięki temu mierniki będą mogły "podsłuchiwać" transmisję. To zapobiegnie kolizjom. W takiej sytuacji "inteligencja" HUB-a jest żadna. Po prostu wysyła po USB wszystko co odbiera od mierników, natomiast to co otrzyma, po wzmocnieniu (74LS07) rozsyła do mierników.  Tym tematem zajmę się jak złożę drugi prototyp.


Aktualnie uruchomiłem pomiar (właściwie wlutowałem 4052, którego wcześniej nie miałem) AC. Jest problem, na który natknąłem się przy okazji multimetru 4.5 cyfry. Prostownik pracuje poprawnie dla napięć do ok 1,3V. Schemat został zaczerpnięty z multimetry 3.5 cyfry, gdzie mierzono napięcia do 200mV. Problem trzeba będzie rozwiązać programowo.


2017-11-13
Problem pomiaru napięć przemiennych rozwiązany. Znalazłem także źródło zakłóceń, którym okazał sie zasilacz. Pozostają testy końcowe i oczekiwanie na PCB HUB-a.

Offline

Użytkowników czytających ten temat: 0, gości: 1
[Bot] CCBot

Stopka

Forum oparte na FluxBB